windows8.1にvagrantで仮想開発環境を構築する


windows8.1のPCに、VirtualBoxとVagrantを使って

仮想の開発環境を構築してみました。

いろいろと引っかかることもあったのでメモ。

基本的には以下の記事を参考に進めていきます。
http://www.webcyou.com/?p=4632

VirtualBoxのインストール

公式サイトからインストーラをダウンロードし、
言われるがままインストール。

Vagrantのインストール

こちらも同様に、公式サイトからインストーラをダウンロードして実行。

Vagrantのバージョン確認

コマンドプロンプトを起動し、以下のコマンドでバージョン確認。

ちゃんとインストールできたようです。

※ここで注意

windows8.1にMicrosoftアカウントでログインしている場合、
ユーザー名が日本語になっている場合があります。
その場合そのまま進めるとエラーになってしまうので、
いくつかのパスの設定を日本語を含まないパスに変更してあげましょう。

VirtualBoxの仮想マシンフォルダー

http://www.virment.com/change-virtualbox-folder/

「ファイル」→「環境設定」→「一般」
の順に開き、
「デフォルトの仮想マシンフォルダー」
を日本語を含まないパスに変更します。
とりあえず以下のようにしてみました。

vagrantのホームディレクトリ

http://qiita.com/sugard12/items/85b2e70c87a354675a0e

「コントロールパネル」→「システム」→「システムの詳細設定」→「環境変数」

ユーザー環境変数に以下を追加します。

こちらは以下のように指定してみました。

boxファイルインストール

パスを変更したら、boxファイルをインストール。
こちらも参考にした記事をもとにインストール。
記事にあったboxのURLの日付が新しいものがあったのでこれを選択。

しばらく待ってインストール完了。

以下のコマンドで取得済みboxを確認します。

ちゃんと取得できたみたいですね。

Vagrantfileの作成

任意の場所に、vagrant用ディレクトリを作成します。
今回は、

という名前で作成してみました。

コマンドプロンプトで、

と入力してカレントディレクトリを移動します。

そして

と入力すると、先ほど取得したcentos64のboxを使って初期化してくれます。

の中身を確認してみると「Vagrantfile」という名前のファイルができています。

仮想マシンを起動

とりあえずここまで来たら、サーバーを立ち上げてみます。

起動しない……

よく調べてみると、64bitOSで64bitの仮想環境を起動しようとする場合、
BIOSの設定が必要なんだとか。
http://qiita.com/rch850/items/ba254063df4a9ff15354

上記サイトとリンク先を参考に、BIOSの設定をなんとか変更し、もう一度チャレンジ。

今度はエラーは起きなかったです。
本当に起動したのか確認しみます。

無事起動しているようです!

念のため、本当に起動できているか確認してみます。

まずは一度立ち上げた仮想マシンをシャットダウン。

次に、Vagrantfileの以下の行のコメントを外し、もう一度起動。

いくつかインストールの確認が出ますがすべてOKにして起動を確認。

その後、puttyでログインしてみます。

サーバの鍵に関する警告が出ますが、「はい」を選択

ユーザー名とパスワードは、デフォルトで「vagrant」になっているようです。

無事ログイン完了!
ちゃんとローカルに仮想マシンが起動しているようです。
まさか、BIOSの設定までいじるとは思いませんでした。

実際開発に使うときに必要なツール類のインストールはまたの機会に。